TEC 5313 NETWORK ADVANCED DATA COMMUNICATION LAB 2: STATIC ROUTING Author: Na

TEC 5313 NETWORK ADVANCED DATA COMMUNICATION
LAB 2: STATIC ROUTING
Author: Nathalia Zepeda and Adedokun Adeyemi (MAR 17 2023)
Reviewer: Dr. Rigoberto Chinchilla
OBJECTIVE:
The main objective of this lab is to give you a hands-on understanding of how to implement routing protocols in a network to allow traffic between different subnets. In this lab, you will learn how to configure both static routing and default routes.
LAB DESCRIPTION:
Routing is the process of forwarding network traffic from one network to another. In a network with multiple subnets, routers are used to forward traffic between the subnets. Routing protocols are used to enable routers to communicate with each other and exchange information about the network topology, so that they can make informed decisions about how to forward traffic.
In this scenario, you are tasked with setting up a small network that consists of three routers: Los Angeles, Portland, and Chicago. Each router is connected to a different subnet. Your goal is to configure the routers to enable traffic to flow between the different subnets.
TOPOLOGY
TASK A: SET UP YOUR TOPOLOGY
Before starting this lab, please read the document “TEC_5313-600_Guidelines to EVENG_MAR_16_2023” to learn how to add nodes in your workspace and how to navigate on EVE-NG.
DO NOT PROCEED TO THE REST OF THE LAB IF YOU DIDN’T CAREFULLY READ THIS DOCUMENT.
For this lab, you will need to add:
Three routers (Router vIOS) (1)
Three Virtual PCs (3)
Once you have placed and named your devices according to the topology on page 1, you can proceed with the instructions in the next task.
TASK B: PRELIMINARY CONFIGURATIONS
STEP 1 – Change the hostname for every router and every VPC.
Change the hostname of every router by using the “hostname” command.
The new hostname should include your last name followed by an underscore and an abbreviated device name. For example, if your last name is “Zepeda”, you can name the Chicago router “Zepeda_CH”.
Router(config)# hostname
Change the hostname to by typing the following commands:
Router> enable
Router# conf t
Router(config)# hostname Zepeda_CH
Chicago(config)# exit
Chicago# copy run start
INSTRUCTION: Repeat the above commands to change the hostname of the remaining two routers (Portland and Los Angeles).
Device
Hostname Convention

Chicago

Los Angeles

Portland

Change the hostname for every VPC by using the set pcname command, as shown in the example below:
VPCS> set pcname Zepeda_CH_H
Zepeda_CH_H> save
INSTRUCTION: Repeat the above commands to change the hostname of the remaining two VPCs (Portland Host and Los Angeles Host).
Device
Hostname Convention

Chicago Host

LA Host

Portland Host

STEP 2 – Configure IP address of the Router Interfaces (All three routers) and the VPCs (all three VPCs).

ROUTER
The basic syntax of the command to set up an IP address in a Router Interface is as follows:
Router(config)# interface Interface_Name Interface_Number
Router(config-if)# ip address IP_Address Subnet_Mask
For instance, an example of the interfaces configurations for Chicago Router is given below:
Zepeda_CH(config)# interface G0/2
Zepeda_CH(config-if)# ip address 192.168.240.6 255.255.255.252
Zepeda_CH(config-if)# no shutdown
Zepeda_CH(config-if)# exit
Zepeda_CH(config)# interface G0/3
Zepeda_CH(config-if)# ip address 192.168.240.10 255.255.255.252
Zepeda_CH(config-if)# no shutdown
Zepeda_CH(config-if)# exit
Zepeda_CH(config)# interface G0/0
Zepeda_CH(config-if)# ip address 192.168.3.1 255.255.255.0
Zepeda_CH(config-if)# no shutdown
Zepeda_CH(config-if)# end
Zepeda_CH# copy run start

TEST:
To verify your configuration, issue the following commands:
Zepeda_CH# show ip interface brief
Zepeda_CH# show run | section interface
INSTRUCTION: Repeat the above commands to configure the interfaces of the remaining two routers (Portland and Los Angeles) according to the following tables:

LINKS ADDRESSES (Between Routers)
ROUTER
LINK 1
IF
LINK 2
IF
SUBNER MASK

LOS_ANGELES
192.168.240.1
G0/1
192.168.240.9
G0/3
255.255.255.252

PORTLAND
192168.240.2
G0/1
192.168.240.5
G0/2
255.255.255.252

CHICAGO
192.168.240.6
G0/2
192.168.240.10
G0/3
255.255.255.252

LAN ADDRESSES
ROUTER
IP ADDRESS
IF
SUBNET MASK

LOS_ANGELES
192.168.1.1
G0/0
255.255.255.0

PORTLAND
192.168.2.1
G0/0
255.255.255.0

CHICAGO
192.168.3.1
G0/0
255.255.255.0

VPCs
To assign an IP address in a specific VPC, use the following syntax:
Zepeda_CH_H> ip x.x.x.x y.y.y.y z.z.z.z
Zepeda_CH_H> save

WHERE:
x.x.x.x is the IP address to assign.
y.y.y.y is the subnet mask.
z.z.z.z is the default gateway.

For instance, an example of the interface configuration for Chicago Host is given below:
Zepeda_CH_H> ip 192.168.3.2 255.255.255.0 192.168.3.1
Zepeda_CH_H> save
TEST
To verify your configuration, issue the following command:
Zepeda_CH_H> show ip

INSTRUCTION: Repeat the above commands to configure the remaining two hosts (Portland Host and Los Angeles Host) according to the following table:
VPC
ADDRESS
MASK
GATEWAY

LOS_ANGELES
192.168.1.2
255.255.255.0
192.168.1.1

PORTLAND
192.168.2.2
255.255.255.0
192.168.2.1

CHICAGO
192.168.3.2
255.255.255.0
192.168.3.1

TASK C: CONFIGURE ROUTING PROTOCOLS
PART I: STATIC ROUTING
Static routing is a simple method of directing network traffic from one device to another by manually configuring a routing table. In a lab environment, static routing can be useful for small, simple networks where the traffic flow is predictable and does not change frequently. However, it does have some limitations. Static routes are not adaptable to changes in the network topology or traffic patterns and can become difficult to manage as the network grows in size and complexity.
STEP 1 – Define the Static Routes
To define static routes, access the configuration mode and use the following syntax:
Router(config)# ip route Destination_Network Destination_Mask Next_Hop

WHERE:
Destination_Network is the network address of the destination network that you want to reach via this static route.
Destionation_Mask is the subnet mask of the destination network that you want to reach via this static route.
Next_Hop is the IP address of the next hop router or device that traffic should be sent to in order to reach the destination network.
Destination_Network is the network address of the destination network that you want to reach via this static route. For a default route, the destination network is always 0.0.0.0. All-zeroes indicate that the default route will match any destination IP address.
Destionation_Mask is the subnet mask of the destination network that you want to reach via this static route. For a default route, the destination mask is always 0.0.0.0. All-zeroes indicate that the default route will match any destination network.
Next_Hop is the IP address of the next hop router or device that traffic should be sent to in order to reach the destination network. All default routes should be defined in a way that traffic flows in only one direction (either clockwise or anti-clockwise).

NOTE:
Keep in mind that you should add a route to reach every network that is not directly connected to the router.

For instance, an example of the static routes configuration in Chicago is shown below:
Zepeda_CH# conf t
Zepeda_CH(config)# ip route 192.168.240.0 255.255.255.252 192.168.240.9
Zepeda_CH(config)# ip route 192.168.1.0 255.255.255.0 192.168.240.9
Zepeda_CH(config)# ip route 192.168.2.0 255.255.255.0 192.168.240.5
Zepeda_CH(config)# end
Zepeda_CH# copy run start
Three static routes are added:
The first static route is for the 192.168.240.0/30 network (link between Portland and LA). Both 192.168.240.9 and 192.168.240.5 can be used as the next hop, as both paths have the same distance. For this setup, 192.168.240.9 is chosen as the next hop.
The second static route is for the 192.168.1.0/24 network (Los Angeles LAN network). In this case, 192.168.240.9 is used as the next hop because this path has the shortest distance.
The third static route is for the 192.168.2.0/24 network (Portland LAN network). For this route, 192.168.240.5 is used as the next hop because this path has the shortest distance.

TEST 1:
To verify your configuration, issue the following command:
Zepeda_CH# show ip route

INSTRUCTION: Repeat the above commands to configure the necessary static routes on the remaining two routers (Portland and Los Angeles) according to the following table:
ROUTER
DESTINATION
MASK
NEXT HOP

LOS ANGELES
192.168.240.4 (PORT-CHI LINK)
255.255.255.252
192.168.240.2

LOS ANGELES
192.168.2.0 (PORT)
255.255.255.0
192.168.240.2

LOS ANGELES
192.168.3.0 (CHI)
255.255.255.0
192.168.240.10

PORTLAND
192.168.240.8 (LA-CHI LINK)
255.255.255.252
192.168.240.6

PORTLAND
192.168.1.0 (LA)
255.255.255.0
192.168.240.1

PORTLAND
192.168.3.0(CHI)
255.255.255.0
192.168.240.6

TEST 2:
Once you have configured the static routes in all routers, proceed to verify connectivity by pinging from one host to every other host (for example, from CHICAGO HOST to EVERY OTHER HOST). All pings should be successful. Use the following command:
Zepeda_CH_H> ping x.x.x.x
WHERE:
x.x.x.x is the ip address of the host you want to reach.
x.x.x.x is the ip address of the host you want to reach.
STEP 2 – Delete the Static Routes
Delete all your previous static routes one-by-one on each of the routers. Use the syntax below:
Router(Config)# no ip route x.x.x.x y.y.y.y z.z.z.z
Where: x.x.x.x is your destination network
y.y.y.y is the network mask of the x.x.x.x network
z.z.z.z is the next hop address
For instance, for Chicago, you would delete the static routes as follows:
Zepeda_CH# conf t
Zepeda_CH(config)# no ip route 192.168.240.0 255.255.255.252 192.168.240.9
Zepeda_CH(config)# no ip route 192.168.1.0 255.255.255.0 192.168.240.9
Zepeda_CH(config)# no ip route 192.168.2.0 255.255.255.0 192.168.240.5
Zepeda_CH(config)# end
Zepeda_CH# copy run start
INSTRUCTION: Repeat the above commands to delete static routes in all routers.

PART II: DEFAULT ROUTES
A default route, also known as the default gateway, is a network route used by a device to forward traffic to destinations that are not explicitly listed in its routing table. It is typically set to the IP address of the next hop router, which knows how to forward the traffic to the correct destination. This enables a device to send data to locations outside its network without needing to know their exact IP addresses.
In this scenario, you will be configuring default routes in the clockwise direction.

STEP 1 – Verify that no static routing is configured in the router.
At the end of part one, you deleted the static routes previously created. Verify with the following command:
Zepeda_CH# show ip route static
NOTE: Nothing should be displayed. If any route is shown, you need to remove it before you proceed to the next step.

STEP 2 – Configure the default routes.

The syntax to configure a default route is similar to the static route syntax:
Router(config)# ip route Destination_Network Destination_Mask Next_Hop
The difference is:

For this lab, we will configure one default route in each router in the clockwise direction. For example, the clockwise default route for Chicago would be as follows:
Zepeda_CH# conf t
Zepeda_CH(config)# ip route 0.0.0.0 0.0.0.0 192.168.240.5
INSTRUCTION: Repeat the above command to configure a default route in the remaining two routers (Los Angeles and Portland).

TEST 1
Verify the configuration with the command below:
Zepeda_CH# show ip route
You should see four routes in your routing table (not specifically in the same order):
The route to your local LAN
The route to the router at the clockwise direction
The route to the router at the anti-clockwise direction
The fourth route is the default route that looks like this:
S*0.0.0.0/0 [1/0] via 192.168.240.5
At the top of the routing table, you will also see:
Gateway of last resort is 192.168.240.5 to network 0.0.0.0
This simply implies that any route Chicago receives with unknown destination will be forwarded to Portland on destination IP Address 192.168.240.5.
Meaning, Chicago will send any traffic it receives to Portland, on interface 192.168.240.5
Using this logic, Portland should send any traffic it receives to Los Angeles, and Los Angeles should send any traffic it receives to Chicago.

INSTRUCTION: Use the above commands as an example to configure the remaining clockwise default routes on Portland and Los Angeles. Remember, we are configuring in the clockwise direction.

TEST 2:
Once you have configured the default routes in all routers, proceed to verify connectivity by pinging from one host to every other host (for example, from CHICAGO HOST to EVERY OTHER HOST). All pings should be successful. Use the following command:
Zepeda_CH_H> ping x.x.x.x
WHERE:
QUESTION:
Why do we configure default routes in a way that the traffic flows in only one direction?
_______________________________________________________________________

Place this order or similar order and get an amazing discount. USE Discount code “GET20” for 20% discount